Beatport tracks losing their waveform while playing (after new update)

Has anyone had an issue after the new update with the Beatport link tracks having the waveform disappearing while playing after the next track is uploaded ?
The track is fully loaded with its waveform but then it disappear after a few seconds that the other track is uploaded. It’s pretty much impossible to play or mix with the software now.
I use latest version of iOS latest version of Djay I use an iPad Pro 11 with an available space of 80gb
Thank you


The same issue occurred with Beatsource.

iphone SE3
iOS 15.5
djay pro AI 4.0.1


Yes I’m having the exact same issue. If I load a Beatport track and wait for it to fully cache, I can jump anywhere in the track and it plays properly with the waveform showing. However, when I load a second Beatport track into the other deck, the first track seems to be losing its cached memory. The waveform disappears and the first track stops playing. This is very repeatable and did not occur prior to 4.0. I have already submitted a support ticket.

Here’s a link to a screen recording of the problem.


I have the same issue.

iPad mini 6
iPadOS 15.4.1
djay pro AI 4.0.1


Same. Mac OS version.

Update: 10:45 ish
I think it’s Beatport. I logged out, quit and reopened the app, logged back into Beatport. Added a couple of tracks from Beatport playlist and after a few seconds the waveform disappeared and the song went quiet.

Did the same with some purchased songs from Apple Music and totally solid, no issues.

Update: 11:09
OK. So this is really weird. I used Quicktime to record the screen so I could post a video and now everything seems to be working fine.

Update: 11:30
Just went back to play more tracks and the issue is back. I guess the last session was a fluke. Ugh


Hello Algoriddim admins,

Can we please get a response to this issue? For those of us relying on Beatport this is a big problem. As I mentioned in the other post (4.0.1 problem when steaming with Beatport), there are a lot of people experiencing this bug since 4.0. I submitted a support ticket last week, but so far there has been no reply there or in the forums. Please at least let us know that you’re aware of the bug and are working on it. Thank you.


I have the same issue with my MacBook Pro, app version 4.0.1
It updated automatically…
One way to “kinda” get around this is to loop the track, it doesn’t seem to stop the audio as long as you remain in loop, but still, not great.
Did anyone manage to find a solution for this?

1 Like

I switched to streaming from Tidal, workers flawlessly.

I’m thinking of switching to Tidal but I’ve seen they have issues with the waveform loading too.
I even tried to download all my tracks to the offline locker but it kept crashing! I’m only an amateur, I can only imagine my frustration if I made a living as a djay. If you truly believe you’re an alternative to Traktor, Serato, Engine, these issues need sorting asap, who cares about harmonious mixing if you can’t do the basics right.
Come on Djay roll the update back until it’s been fixed for beatport users because at current this is unusable.
Ps. Could these issues be caused by not having enough free storage space on device???

1 Like

Yes well said…Thank you. I do use this system a lot with private parties gig and I have an important one on the 11th of June
I have lots of storage available on my ipad and still not working … so frustrating : (
Went even back to the old version but it does not have Beatport link

Mine also crashes when trying to add or remove tracks from the offline locker. I have over 60GB of free space on my iPad so that’s not the issue.

When I load a track from beatport the waveform is showed but then it disappear after a few seconds that the other track is uploaded or tried to mix. It happens in mixing manually or in automix . It’s pretty much impossible to play or mix with the software now. 4.0.1 for iOS. A weekend without working :cry:

1 Like

This problem has been reported by others in this thread already.

I am using a iPhone 13 pro with djay pro AI, got updated automatically yesterday to Version 4.0.1.

After update, I was told to re-login to beat port and done. Then I start to dj from saved track list including song steaming from Beatport. The track was loaded and play, when I play another track for 5-10 sec, cross fading, or one time I press the panel switching (PRO button), the audio stop, waveform gone, but the deck told it was still playing with track time still courting down…
This problem happened so frequently, that the app now is not usable at all.

Another problem, tonight I am giving up adding a song steaming from Beatport to the Djay playlist and instead adding this song from tidal. Then no matter how many times I add this song from tidal, the playlist told me the song is from Beatport and experience the same problem as above when I play…so in a way it stuck.

I like to add all steaming songs from Beatport and tidal to djay playlist and organize as a set when adding cue points etc. Now I having much trouble doing this.

Pls help and give some advise. Thanks.


Same thing is happening to me exactly how you describe making the app completely unusable right now. I haven’t tried it with any downloaded songs mind you. Just streams from Beatport.


Same here. There is already another thread discussing this issue:


Same here. Infuriating.

1 Like

I was close to giving Beatport streaming a go in djay, but after reading about these issues, I’ll hold off from that subscription for now.

1 Like

So I had this issue… so o tried reinstalling the app, and now my entire library has been deleted. Is there a way to restore.

I have tried reloading the file and unfortunately it is greyed out.

Really unhappy customer.

1 Like

I am sorry to say but my experience of the app since new updates has been awful. Thinking of ditching my subs. I am on a big downer, so many problems.