Djay 2 + Tab S 10.5 + Wego 3 = No Sound

Just spent tons of money and got a samsung tab s 10.5 and pioneer wego 3.
Tab S on android 5.0.2 (latest update) and wego 3 on latest firmware
Djay 2 latest revision 2.2.2.
wego controls the app nicely but no sound out of Wego, not out of the headphones jack and not out of the master output.

I understand that djay 2 supposed to send sound through the controller itself

any idea what might be wrong ?


Sadly older tablet’s “USB Audio” was done a bit different than it is done since lollipop.
All tablets i tried that came out with 4.X and then upgraded to android 5 did not work properly with USB audio and Djay 2. All tablets originally released with 5.X worked properly with USB audio (Nexus 9, Tab S2 both 8.0 and 9.7), Pixel C etc…

Hope this helps.

Hi there,

could you please update the application to 2.2.3 and afterwards try to play music through the WeGo via the Google Play Music application.
Thank you in advance, this would be a good information in order to help you with your problem.

Lukas E.

Hi Lukas, your question sent me on 3 days hunting
No sound came out google play music

Started switching ROMs going back and forth in android releases back to KitKat then lollipop 5.1.1 then marlshmello no luck all same no sound out of google play no sound out of djay2 but full midi response

tried simple USB audio stick I had bought few years ago, working fine!!!

BTW I have both wego first edition and wego 3 both no sound through google play music

I can see audio being switched to USB but no sound

Yea seems this is the case,
I would have like algorithm, or even just the community to compile a list of android tablets that works

I’ll try to get my hand on one of those you mentioned and try it out

Thanks Jonathan