Djay + DDJ-Sr2 phono/vinyl not working?

hey folks, wondering what I’m doing wrong. Trying to play vinyl through DJ AI Pro.
I’m using Pioneer ddj-sr2 which has phono inputs.
I’m on a mac.
I’m on Djay v4.1.7
When I don’t have Djay turned on the controller will play the vinyl through the phono input but once I turn on Djay then it cuts out. There must be a setting to make it work so curious what it is and hopefully this is a dumb question and it’s an easy solve!
thanks for help in advance!

1 Like

Hi @playjazzloud,

Thanks so much for sharing this topic with our community. I’d be happy to help you in whatever way possible!

To start, could you please answer the following questions:

  1. What Mac model are you using?
  2. What macOS version are you running?
  3. Has this issue continued to happen in the latest version of djay, v4.1.9?
  4. Is this issue consistently reproducible?

Eagerly awaiting your response. Have a fantastic day!

hey thx for responding. here are the answers

  1. What Mac model are you using?
    13" macbook pro 2018
  2. What macOS version are you running?
  3. Has this issue continued to happen in the latest version of djay, v4.1.9?
    I’m running v4.1.7
  4. Is this issue consistently reproducible?
    yes, I’ve tried a number of times now. I can see about upgrading the software to 4.1.9, I didn’t know there was an update. and see if that solves.


hey @NathanielAlgo any tips on how to fix this? I’ve tried using Serato and no problems with the controller and turntable. it comes through fine. and with DJAY if I go to the DVS settings I can see that it’s registering the turntable but no sound is coming through. thx!

@playjazzloud are you trying to play regular vinyl records or use the turntables for DVS?

@playjazzloud sounds like might need to install a MacOS driver for this:

Also, apparently the DDJ-SR has two operational modes. Perhaps this is the problem. Maybe worth trying at least if the driver above doesn’t work.

hey @Slak_Jaw going to give this a look this afternoon. thanks and fingers crossed. I’m trying to play regular vinyl and not the DVS.

Okay, hope that helps. Please report back and let us know either way.

sadly that didn’t work. did the reset a couple times and the same. I tried with a control vinyl and the DDJ and Djay is clearing picking up something from the turntable input cause I can use DVS and the deck to control a song in the system. but playing a real vinyl record through the DDJ only works if Djay is turned off.
if you have any otheer tips @Slak_Jaw would love to hear :slight_smile:

@playjazzloud are the switches on the top of the SR2 set to PHONO/LINE?

@playjazzloud can you please share a screen shot of your Settings>Audio Device Setup in djay?

yup have that set to phono/line and also on that back at the input connection there’s option to set to phono or line and it’s set to phono and I’ve try it set on line as well in case that changed anything.

and for “audio decive set up” do you mean this tab in “settings” it technically is called “devices” so wanted to double check.

@playjazzloud okay, thanks. Yeah, that’s the right screen shot. Try switching to External Mixer mode.

what do you think the settings should be? also to circle back to your very first message I went and grabbed the firmware download which I’m pretty sure I did before when I first got the DDJ-SR2. sadly didn’t change anything.

@playjazzloud use channel 1-2 for Decks 1-4, channel 3-4 for Pre-Cueing.

If that doesn’t work, try setting Deck 3 and 4 to None.

tried those and a few other options but nada. really appreciate you trying.

Sorry that didn’t solve it. I don’t have a SR2 or turntables so it’s a tough one for me to troubleshoot.

@playjazzloud the only other thing I can suggest at this point is to play around with different combinations to see if you can find a setting that works. Maybe try setting the top switches on the SR2 to Deck 3/4 with the External Mixer mode in the settings still on.

yeah that makes sense to give it a try. generally surpriesed this hasn’t come up and isn’t something someone has figured out how to fix, I did a deep google search! will probably have to default to Serato for times when I want to use the turntable.