iOS: Local Music not working on djay 5.1.5

With the new djay update 5.1.5 none of my “local music” will work. I have an iPhone 15 Pro max and use iTunes Match. This is a service which allows you to stream your Mac OS Apple Music local library on any device. What I’ve done is add my whole library to my Mac and then I can download playlists for local music on my devices. I’ve downloaded thousands of songs locally onto my iPhone and even have them organized into smart playlists in my collection. This is how I’ve always organized my music in djay for several years.

Now, whenever I attempt to add any song which is in my local music (or if I try to add any of these songs from the my collection even) I get an error.

This makes the new update completely unusable for me.

Please fix asap! The app is now essentially not functional for me. I’ve added a screenshot of the error I get.

Hi @avi530,

  1. Please log out of Apple Music Streaming, TIDAL and any other streaming services from within djay on your iPhone.
  2. Close djay.
  3. Also log out of the above streaming service apps on your iPhone.
  4. Perform a Forced Restart of your iPhone (Force restart iPhone - Apple Support).
  5. Launch djay and log back into your Apple Music Streaming service and test again. Thanks!

Thanks for the suggestion @Slak_Jaw I did try this and it did not fix the issue.

Also, how does one sign out of Apple Music on a device? That would require me to sign out of my entire Apple ID and lose iCloud iMessage etc.

Either way I’ve tried all of the other steps above with out luck. I still get the error.

Interestingly enough, if I go to the Apple Music section and try to add the songs that way they take a little longer to load (probably because they’re being streamed not local) but they work. Neural mix will also not work on these songs which makes it clear the songs are streamed not being loaded locally. Again these are MY songs I have downloaded onto my device through iTunes Match. They were downloaded from record pools then added to the Music app on my MAC. I download these songs directly through the music app on my phone using iTunes Match and all of the songs are local and available offline in the music app. Again this has never been a problem before this update. Seems to be something with iTunes Match most likely. Issue is only with “Local Music”

This same issue is happening on my iPad as well, just updated to 5.1.5. No issues with Tidal tracks, but get the above error message for all of my local music. I also tried the suggested solution above with no luck. Please look into this asap! Thank you.

1 Like

Okay, thanks for the updates. I’ll have to share this with the engineering team to see if they can reproduce the issue and offers some suggestions as this is working fine on my setup. I’ll report back when I have news.

1 Like


When you say working find on your set up, are you using iTunes Match to get the music locally onto your device or are the local songs added directly to the device through iTunes?

I wonder if there is some licensing issue with the match songs?
Either was wasn’t giving error before this update

I do not use iTunes Match. I use a wired connection between my laptop and iOS device and sync my local library using iTunes/Music.

If I had to guess the issue is with iTunes Match. I like this service because I have accumulated a huge iTunes library on my Mac, this allows me to pick and choose which songs I need locally on my iOS device but still have access to the full thing by streaming.

Do you use iTunes Match?

The engineering team was able to reproduce this issue with some local music songs, but the majority are working fine. They are investigating further and I’ll share news here when I have it. Thanks!

I have the same issue. I’m not using iTunes match or any streaming the local music will not load. I’m so glad I don’t have a gig tonight!!

iPad Pro and iPhone 12 Pro

Same issue. All local music won’t load at all.

1 Like

Hello everyone. When reporting and commenting on bugs, please provide full details about your setup to help us analyze, troubleshoot and fix them efficiently. Thanks!

  • Device model (e.g. 2020 iPad Air 4th Gen):
  • Version of operating system (e.g. macOS 14.4.1):
  • Version of djay (e.g. 5.1.2):
  • Hardware/controllers used (e.g. Reloop Mixon 8 Pro):

Summary of the issue:

How to reproduce the issue:

I just updated my 2021 iPad Po 5th generation to 5.1.5 update and now I cannot load any songs into a deck… I keep getting this notification.

Could not load track
The operation couldn’t be completed.
(kCFerrorDo-mainCfNetwork error - 1002.)
Now I can’t do anything.

Yep I think quite a few of us are getting this, no local music will load at all. This isn’t great. If you’re a working dj do not update. That’s my suggestion. I’ve only updated on my iPhone so far.

Unfortunately, I updated on my iPad first as I said earlier thankfully I’ve not got a gig for weeks. I’m on holiday, but if this was happening in the middle of my busy winter, I would’ve shit myself.

lol. Sorry man but that’s made me laugh :joy::sunglasses::joy:

1 Like

As I said, it’s all good. I was doing like five gigs a week for months but now I’ve got a month off.

That’s my own music. I don’t use streaming services.

Every update something wrong!!!

1 Like

Just a friendly personal reminder from a long time, experienced DJ… please always fully backup up your system before updating your OS or DJ software and NEVER update before an important gig. This applies to all OS’s, DJ software and hardware.

I posted my personal list of tips on this forum long ago before I joined the Algoriddim team and I always follow these religiously no matter what software I use: