Numark iDJ PRO Support for djay Pro

I just ordered a new ipad and Algoriddm idjay to work with my Numark iDJPRO. I was planning to stream from Soundcloud and just wanted to check in here to make sure this is all going to work.

Please advise.

Hi @roco50, unfortunately the Numark iDJ Pro is no longer on our list of officially supported hardware for iOS. This controller is quite old now and was originally designed to work with djay Pro 2 which is no longer supported or available unless you previously purchased it years ago. Also the iDJ Pro uses an old 30 pin connector so you will need an adapter to make it work with a new iPad and the overall fit could be an issue depending on your iPad model.

Please see below for our list of officially supported hardware for djay Pro 5 on iOS:

There is some additional discussion about this controller in another topic as well:

I have the adapter. The ipad will fit. The controller is excellent. I did buy idjay pro 2 a long time ago, but imagine it is not in the app store any more?

There are many others looking for support Algoriddm iDjay for this controller. Is there some reason you stopped supporting it, as there is a huge Algoriddm logo on it!

1 Like

@roco50 if you previously purchased djay Pro 2 you can reinstall it using the following procedure:

@roco50 you could also try it with djay Pro 5 to see if it works and provides a built-in MIDI Mapping. If not, you might be able to custom MIDI map it yourself. Here’s a guide for MIDI Mapping on iOS:

1 Like

So there is a chance it will work with Djay 5?

1 Like

@roco50 there’s a chance you’ll be able to make it work with djay Pro 5, but I don’t have this controller to confirm. So, you probably won’t know until you try unless someone else with this hardware can confirm (@maurizio_T).

1 Like

I will try later on this afternoon and report back…
From my memory the last time I tried,
it wasn’t recognised in Djay, only Djay 2

Ok I have tested it and can say that it works perfectly with Djay 5.03.
You have to enable split cue in settings but other than that, it worked flawlessly.
The midi map can be edited although there’s not much left on the controller to be changed,
The only edit I did was set the Reloop button to Toggle Neural/EQ.

This should now be added to the list of controllers on the Algoriddim website

The only thing I should add is that for some reason it wouldn’t work with my iPad 9th Gen… It may have been the cable but I don’t know…
I tested it using my iPad 7th Gen and iPad 5th gen and it worked.
It also worked on my iPhone X

Yes see my post above

This is excellent! I can’t wait to try. This controller was built so well
an really deserves to be supported. iPad arrived tomorrow. I’ll report
back

Thanks for checking this @maurizio_T. Really appreciate the help on this one! I have already forwarded this to the dev team to see if we can get it added to the official hardware support page. Thanks again!

1 Like

Ok - So I booted up new ipad, connected the controller, downloaded the djay app (free version so far), and linked my soundcloud account.

ipad is still playing music instead of routing sound to controller.
midi device not available message?

How did you get this going?

Maybe I need to download a midi utility for iPad?
Or is this only in the paid version?

Any assistance would be appreciated.

@roco50 you need a paid subscription to use the controller.

1 Like

Also check to see how new the iPad is, As I mentioned, it wouldn’t work for my 9th Gen but worked on my 5th and 7th Gen

Yeah, this is a 9th Gen.

Does not work. The controller is not active and never takes over the sound from the iPad.

Is it worth trying to find an older generation iPad?

Yeah unfortunately that’s what I found…
As cheap as older iPads are to buy, you could try it,
It definitley workes on 7th Gen.

Is the 30pin to lightning adapter you have the genuine Apple one?
I tried an aftermarket one and it didn’t work but bought the genuine one and it was fine

Any idea if it works with 8th gen?

Kindest Regards,
Rob Conley

Sorry I can’t confirm that,
I only tested 5th gen and 7th gen,
I can’t remember if Neural worked with 5th gen though but it did with 7th

Was the 30pm to lightning adapter a genuine Apple one?