Reporting Cover Album Disappearance Issue in djay Pro for macOS Sonoma 14.3 Beta 1

Dear Algoriddim Team,

I hope this message finds you well. I am writing to bring to your attention an issue I have encountered while using djay Pro on my MacBook Air running macOS Sonoma 14.3 beta 1.

Problem Description:

During my DJ sessions, I’ve noticed a recurring problem where the cover album disappears approximately 5 to 20 minutes into the session. To temporarily resolve this issue, I’ve been closing and reopening the app. However, I believe it’s crucial to address this matter comprehensively to enhance the user experience for all djay Pro users.

Environment Details:

  • MacBook Air M2

  • macOS Sonoma 14.3 beta 1

  • djay Pro app Version 5.0.3

Additional Information:

I participated in beta testing for macOS Ventura last year (2022-2023), and a similar issue occurred with the cover album during that time. It seems that the problem has persisted into the current beta version of macOS Sonoma.

Proposed Solution:

I am willing to assist in resolving this issue by actively participating in beta testing for any updates or patches related to this matter. I believe that a thorough beta testing process on different Mac configurations will help identify and address the root cause of the cover album disappearance.

Steps to Reproduce:

  1. Open djay Pro on macOS Sonoma 14.3 beta 1.

  2. Initiate a DJ session and observe the cover album.

  3. Note the disappearance of the cover album within 5 to 20 minutes of the session.

Categories with Issues:

  • Cover album disappearance

I appreciate your attention to this matter and your dedication to continuously improving the djay Pro experience. Please feel free to reach out if you require any additional information or if there are specific steps I can take to assist in resolving this issue promptly.

Thank you for your time and consideration.

I’m on macOS 14.2.1 (23C71) and it happens to me as well, but it is not time based. There definitely is a trigger though, because once that condition is met and I start loading tracks, the album art disappears, track by track, until I restart djay.

Hello,
thank you to submit this bug, I am exatly the same situation, you explain perfectly the trouble I have. For me sometimes it’s the cover disappears after 5-10 min and sometimes after 45 or on hour.
the difference is that I am on Mac Os Ventura 13.5.2 but same mac book air M2.

The only thing possible to resolve this problem is to restart Djay pro.

I use this software cinch the first edition, I love it, and I use it for professional purpose. I am an ecstatic dance DJ. I really want to keep it, but If we can see any cover, and I can fix it, I’m going to have to get rid of it and use the competing Dj software.

Joël

Hi @Cooljackdj, please note that djay does not support beta versions of macOS. Please update your macOS to a non-beta version and let us know if you are still experiencing this issue. Thanks.

I experience this issue and am not on the beta.

Screenshot 2024-01-18 at 2.37.37 PM

Thanks for the info @kokernutz. Can you please capture a video of this, upload to your Dropbox/Google Drive, enable the appropriate sharing permissions, then share a link to the video here? Thanks.

Try this:

Thanks for the video @kokernutz. This is very helpful. I have forwarded this to the engineering team to see if they can reproduce the issue.

1 Like

If I were to take a stab as to what might trigger it, is that I have Apple Music open and I am making updates to genre/comment/etc or downloading new music and I then go into djay and refresh the library. Back and forth between the apps.

1 Like

Thanks for the additional info @kokernutz. That should help us with troubleshooting this issue.

Hello, I noticed in the folder Music/djay/djay Media Library keeps a backup of the old version.
I deleted the new version of the media library and replaced the back up version with the same name.
this file version dated 3 December 2023.
When I used Djay with this backup version of the media library, I’ve had no problems of the visible cover. I used one week with any problem, until I started to have some new music in “Apple music” analised them and put some cuepoint and looping segment. This problem of the missing cover is reappeared.

I have usually Apple music open, in the same time of Djay pro. Can i fix this problem when “Apple music” is close?

Thank you to continue to look and search of this bug!

Cheers

Hello everyone. I’ve just returned from vacation and wanted to follow up on this topic. Can you please confirm if the album cover issue is only happening with the iTunes/Music source? Or does it also happen with My Collection, Tidal, SoundCloud, Beatport, etc? Thanks!

I really only use the “Local Music” node but I will try to test with the other sources.

Heya, just discovered something new related to this issue.

For some reason, the album art is displayed in the related tracks section even if it is missing in the browser listings.

I recorded a video to help illustrate this:

Thanks for the additional info and video @kokernutz

@kokernutz,

The engineering team has not been able to reproduce this issue locally so it’s challenging to debug further. Can you please test if not using the Music app at the same time as djay makes a difference?

Will do! (Just updated to 5.1.2, too.)

Yes, still happening. Apple Music was not open.

Covert Art eventually disappears in the browser listing, but when you drag it into another track’s Related Tracks area, the cover art does show up.

One detail I neglected to mention, I use the Re-Embed Artwork script from Doug’s Applescripts to makes sure the artwork is embedded in the file, just in case whatever program I’m using doesn’t integrate with Apple Music. https://dougscripts.com/itunes/scripts/ss.php?sp=mxreembedartwork

If it makes any difference, almost all of these tracks are purchased through the iTunes Store.

Also, with some files, the artwork never disappears. I’ve tried looking at the metadata in Finder and in Apple Music and I can’t find any rhyme or reason why those files seem unaffected. I’ll try to track to see if it’s the same files between sessions.

Thanks for the additional details @kokernutz. I’ve passed this onto the engineering team.