Tidal 'Hi-Fi' - only first 6 beats appear in the waveform!

Hi All - this is my first post but I have been using Djay Pro for many years.
Over the last week I have developed a new problem:-
When I load a track from my Tidal ‘Hi-Fi’ subscription only the first 5 or 6 beats are showing in the waveform.
I know sometimes it takes a while to load but these never load, no matter how long I wait.
I have upgraded to the latest version of both Djay and Tidal and cannot resolve the issue.
The affected tracks were all working fine last week!

Sometimes the complete waveform appears for a split second and then everything disappears except for the first few seconds of the track.

The only workaround I can find is to go to ‘Normal’ quality and then the tracks load correctly.
I have restarted my router etc.

Has anyone else had this problem and if so how did you resolve it?

Rgds,
Paul.

1 Like

I have the same problem and could only temporarily fix it by lowering the quality to High. The problem is that I have a Tidal HiFi account, so I should use the superior quality

I have the exact same problem and it began this past week, also.

I’m on an iMac Pro and, like you, tried every workaround I could think of with no success.

The problem seems to be with DJ Pro. I also use my Tidal HiFi subscription with Pioneer DJ Rekordbox and it’s working just fine at HiFi quality.

1 Like

Hi - I am glad (in a way) that it is not just me. It must be something to do with the Tidal / Djay Pro compatibility that has changed in the last week - perhaps a Tidal upgrade has caused the glitch?
Can anyone from Algoriddim give us a clue please?

Yes it is very frustrating - I pay for a hi-fi subscription but can’t use it in my favourite DJ application.
I upgraded my OS and then moved to Djay Pro AI in the hope that would fix the problem but it is exactly the same!

And I have seen the issue across devices. Tried on my phone and iPad and still the same problem. Serato works just fine, so it isn’t Tidal. It is disappointing because djPro is my favorite software, but with low quality sound it is no good

OK that"s great info and thanks for your feedback. I have raised this with the Algoriddim support team so hopefully we will get some news (and hopefully a fix) for this very annoying new bug soon!

1 Like

Exactly the same here…

Weird one innit? Hopefully we can get a resolution soon from the Algoriddim support bods :slight_smile:

Hi All,

Thanks for bringing this to our attention. Our team is aware of the issue and is currently investigating this.

It appears that this issue only occurs when using the TIDAL HiFi Quality settings in djay. As already shared by @DJPaulMack, a temporary workaround to the issue would be to set the TIDAL Quality settings in djay to High or Normal. You can do this by following these steps:

For Mac: Go to djay Pro AI’s Preferences => Library => Under TIDAL change the Quality settings using the drop-down menu.

For iOS: Go to djay Pro AI’s Settings => Library => Under TIDAL change the Streaming Quality settings.

Thanks in advance for your patience and we’ll keep you updated here with any new information.

2 Likes

Thank you Emily :slight_smile:

I’m using a tidal hi fi subscription with djay pro 2. All was working well until yesterday.

When I load tracks, only the first 2-3 seconds of all tracks are loading.

Video - https://photos.app.goo.gl/u9MEFS4Gf7bF4NpAA
Photo - https://photos.app.goo.gl/DVnp425Q9mK6u5Mu9

I’ve tested loading tracks with Soundcloud Pro and all is fine there. This issue is only happening with Tidal.

Please let me know what to do as I’m frustrated I can’t use the Djay Pro 2 or my tidal subscription.

Appreciate your help.

Device
iPad Pro (12.9-inch) (4th generation) - software version 14.4.2

DJAY PRO version
3.6.7

Thanks,
GeeKay

Hi @GeeKay,

Thanks for reaching out about this. I’ve moved your topic post over to this already existing thread about the same issue. Our development team is currently investigating this. In the meantime, please see the temporary workaround posted above.

Do we have any news about this issue?

Hi Emily - this is still an issue. Do you know if a patch will be made available soon please?

Thanks :blush:

Hi @DJPaulMack and @afsaba,

Thanks for checking in about this again. Unfortunately, I don’t have any updates for you at the moment. Our development team is still checking into the issue. I’ll push it again with our team and will keep you posted here with any new information as soon as it’s available. Sorry for the inconvenience and thanks in advance for your continued patience.

Please fix this ASAP. It has been 3 weeks already.

Hi Emily - thanks for your response. It would be good to know if your dev team have recreated the issue and have a plan for fixing it soon. The bug appeared overnight and is impacting numerous TIDAL users by the looks of things. I cannot realistically continue to use DJAY Pro without Hi-Fi quality and am afraid that I may have to switch to another application unless I know that this is going to be fixed in the short term.
Thanks :slight_smile:

1 Like

I checked again today but still it doesn’t work. Same as you DJPaulMack, I had to use Serato due to the obvious sound quality difference. I am going to wait a bit more before migrating for good, but this is taking too long.

Hi All,

Thanks for checking in on this and also for your continued patience. Our team is still investigating the root cause of this issue in order to provide a fix. It would be very helpful if some of you on this Topic thread would be willing to provide some additional information to assist in our investigation.

If so, please email us directly via our Contact Form. Please reference this Forums post in the Subject or Description fields, and please also include which platform (i.e., iOS or Mac, or both) you’re using and which version of djay Pro AI you’re using. Thanks in advance for your assistance in troubleshooting! Hope to hear from you soon so we can get to the bottom of this.