DJay crash after 4 hours of playing

  • Device model: iPad Pro 2018 1TB
  • Version of operating system: iOS 17 (latest)
  • Version of djay: 5.1.4.
  • Hardware/controllers used: Reloop Mixtour

I played a gig with last week started at 8PM. After a four hours of playing without issues, DJay app started to slow down (Lag on responses). After a few minutes the playing track stopped and I could not play anything. Shut down the app, reopened, but without fix.
Ended up restarting the complete ipad and then everything worked again.
Unfortunatly it ruined a set, but gladly I could play on with Rekordbox on my Pioneer.

What could have caused this and is this a known issue?

kind regards,


That sounds like it could be a memory leak, and there are other similar reports.

Were you playing files stored on the iPad or were you streaming (if so, from which service)?

1 Like

I was using Apple Music Streaming service, as I only use this for requests.

As well as your own music on your iPad?

1 Like

Hi @MRDJ, thanks for the information.

  1. Did the app crash or did you manually restart it?
  2. Can you please also submit an official support request via the djay app under Settings>Contact Support? This will allow us to gather more information about the issue.
  3. Was your iPad plugged in and properly charging?
  4. Did you happen to notice any overheating of your iPad?
  5. Were you running any other applications at the same time? Perhaps an iCloud backup or Automatic updates?


  1. I needed to restart manualy, because the app was not responding anymore.
  2. I will when I am at home (done)
  3. Yes is was on the original iPad changer
  4. I did not find the iPad extremly hot, but it was standing so I could not exactly tell.
  5. The only app running in the background was Notes app. Here I have all my info for the event. No backup or updates were running and all was in Do Not Disturb mode.

kind regards, Maik

Yes, I also play my own music locally from my ipad. But mostly streaming for the requests

1 Like

I have never had the full crash during a set but have had one deck stop playing which was easily fixed by pressing play.
Haven’t had that in a while and I have just picked up a iPad air 5th Gen to replace my iPad 9th gen as I felt the 9th Gen was beginning to run at maximum capacity memory wise,
The new M1 chip is much faster.
I also follow Slak Jaw’s recommendation in that I have
Do not disturb on,
Bluetooth off,
All other apps closed
Perform hard reset before every gig.
This seems to have cured the problem

MRDJ, you write you are using Djay pro v 5.1.4 but 5.1.4 has not been released yet.
5.1.3 is current version

You are totally right. Here the things send from the program to Algoriddem:
App: djay 5.1.3 (57887)
Version: 5.1.3
OS: iPadOS 17.3.1 (21D61)
Language: English
MIDI devices: MIXTOUR (0x26AD8A39), Netwerk Session 1 (0x0) [unused]
Streaming services: Apple Music

Product: pro_loyalty_3.yearly-Paid-Active
Usage frequency: Once a week
Usage purpose: Private DJing, Semi-Professional DJing

1 Like

Yes one deck stopping with playing I also noticed, but thought I could have touched something…
I think it is a good idea to hard reset before a gig. I use it almost 3 years now and never had an issue. This is the first time. Probably I will update my iPad soon, but damn those things are so expensive …

1 Like

suddenly stopping a playing deck is a nightmare to any dj :scream:
i use Djay Pro on a iPadPro and on a macbook pro (both on 5.1.3)
yesterday i was sorting/creating playlists for some hours (on my macbook) with Djay and suddenly while scrolling thru some folders/playlists, first i got some small graphical glitches, within seconds the complete screen was scrambled, nothing was anything readable. i tried alt-tab to switch to another app but i could not see anything readable. i even was not able to force-stop anything. i could not see what i was doing on the screen . the only way out was by pressing&holding the powerbutton for a hard reset. after reboot i did a full hardware diagnostics test everything is ok. system could not find any problem. it was not overheating. my macbook did not feel very hot.

i’m not sure if this was caused by Djay app or some other hardware issue, but it should not be happening :face_with_spiral_eyes:

it was not reproducable. i tried to trigger the same crash/glitch again. started Djay pro and finder and applemusic in the background for some hours. the crash did not occure again.
(btw: there was no controller connected)
The systemlog is as clean as a whistle

Thanks for the additional details @MRDJ. Based on what you’ve described, I don’t really have any recommendations other than to review my personal iOS specific tips. In the meantime, I have already shared this with the engineering team to see if they can reproduce the issue and offer any suggestions. I’ll report back when I have news. Thanks!

1 Like

Blockquote Yes one deck stopping with playing I also noticed, but thought I could have touched something…

OK, so I’m not the only one, I also experience one deck randomly stopping from time to time, and sometimes hitting the play button on my controller won’t fix it right away. I think it could have something to do with shift getting stuck on or something like that.
I am on a DDJ-flx4, on a MacBook Pro, what type of controller are you using?

1 Like

I’m using a Rane One and it would happen frequently before but haven’t had it since, I also recently upgrade to a iPad Air 5th gen but haven’t had the issue happen yet.
I’m doing a 5hr gig on Saturday night so will test it out then

i was on a Mixon 8 which had jog-tracking issues and occasionally one deck stopped.
The Mixon 8 was returned to the store and now i’m on an Allen&Heath Xone PX5 and a pair of Dennons LC6000. this works really well with Djay Pro (so far)

first i thought suddenly stopping decks only occurred on Mixon 8, but now i read on this forum there’s also stopping decks on other controllers across DDJ-flx4, Mixon 8, Mixtour and Denon LC6000.
This scares me :flushed:

with this new gear i got, i’m testing stuff extensively to see if this can happen to my gear (using DjayPro) i did have one issue stopping the music while using Djay, but that was caused by a system-notification on my ipad regarding there was something wrong with my apple-id. after sorting the apple-id thingy (had to re-authenticate) there ware no stopping decks anymore. but reading other stories about stopping decks across different brands with Djay really scares me. i will do anything to prevent that.

So just an update,
Played a 6hr gig last night and it ran flawlessly and without a hitch…

Rane One,
iPad Air 5th Gen,
Djay 5.0.4.

Still followed the same routine before any gig,
Hard reset on the iPad,
Shut all apps besides Djay,
Run Do Not Disturb.
Wifi on via my phone Hotspot for Tidal (which I only used for one track)

I think since upgrading to the iPad Air 5th Gen, that has been the cure to my crashing


Thanx for letting us know you had no issues @maurizio_T

I’m curious what usb-devices you use. Do you have an original apple camera usb3 adapter or a cheap knock off? Any usb/lightning extension cords. What poweradapter, usb-hub etc.

I have a 2017 ipad pro 10.5" which has lightning usb socket. Because i dont want the weight of the usb adapter with the tiny cord, hangin on the lightningport of the ipad, i use a lightning extention cord between the camara-adapter and the iPad.

I have tested this setup for several hours without issues in the djay app, but i noticed the batterycharge level goes up and down all the time.

Meaning it is using more power than it can charge at the same time. The usb3 adapter is powered, the usb-hub is powered
It looks like there is some voltage-loss in the lightning extention cord. I’ m worried the ipad will run out of battery at some point anyway.

When you dj, you should not be worring about battery levels etc but focusing on your mixing in stead

Please tell me your setup😇

1 Like

Thanks for the update @maurizio_T. That’s great to hear!


With the iPad Air gen 5, it has a usb c port so l use a USB hub and use a usb c charger,
Previously with my IPad 9th Gen thst had lightning port, I used the genuine Apple camera to usb adapter but still used a USB C charger with a USB C to lightning cable and never experienced any charging issues,
Also not experiencing any charging issues with the current setup either

I believe the new djay versions 5.0 and up are probably using a bit more processing power and my 9th Gen iPad may have struggled but looks like the iPad Air 5th gen with its M1 chip is handling it better