Jogwheels Reloop Mixon 8 pro not tracking properly

Yo, thanks for reply!
I did open a ticket and uploaded some vid for the team to see what happens with me.
I suppose they are trying to resolve it with some FW updates, atleast following one thread from props mcfly in FB… Hopefully someone finds solution for this.
Then there wouldnt be the hassle between sending old and waiting for new one ^^

You’re welcome @Lex_Willer. Thanks for the follow up. Please share any news that you get here for other users to read. Thanks!

I have more or less the same problem that’s in the video.
I notice 3 things:

  • I was unable to reproduce the problem when using DJay Pro for MacOS. It only occurs using DJay Pro for iOS (using an iPad Air 5th Gen).
  • The situation apparently disappears if I disable the Vinyl option on the Mixon 8 (using the buttons SHIFT + SLIP/VINYL).
  • When using VirtualDJ (for which I have a full licence), the problem doesn’t shows.

I think it is a software problem, eventually with the Mixon 8 configuration on DJay Pro and not an hardware problem. Or something to do with the combination hardware / firmware / software.
I already sent a request for help both to Algoriddim and Reloop.
I think they should try together to seek a solution to the situation that’s affecting many people.

Thanks for the detailed information @MrBig1964. I’ve forwarded this to the engineering team for further review.

This exactly corresponds with my similar issues on the midi fighter twister.
I hope Algo developers step over their shadow and start looking what is going on.

Reloop requested my to test firmware 5339.
I will be testing over the weekend but I have not managed to provoke any errors this evening with the new firmware loaded to the deck.

4 Likes

I have firmware 5339 in my Mixon 8 controller. It is the firmware version that came with my controller.
All the problems I mentioned earlier have occurred with firmware 5339.
Didn’t make the test with previous 5039 firmware which is the current firmware available on Reloop’s website.
I notice this different versions on my controller and in the website and alert Reloop for the case. They told me to use 5339 and that they would update the website but, until now, 5039 is still the latest version available on the website.

Very odd indeed. My Mixon 8 is still at repair 6 weeks now. Very bad service indeed. I’ve put a complaint in. I think repair centre is waiting for Reloop to update the firmware. Don’t think I’ll be getting another Mixon 8 after this experience. Hope yours works out.

I think it can be a mix of software and firmware issues, not an hardware situation.
My Mixon 8 runs perfectly with Virtual DJ, for instance (I have a VJ Pro license).
I would rather prefer to use DJay Pro, anyway, due to the extensive support of both MacOS and iOS, namely the later which is perfect for DJaying in the move.
Algoriddim and Reloop must colaborate closely to solve this situation ASAP as it could ruin the image of both on the prosumer market.

1 Like

Mine is hardware I have just been told. Waiting for jog wheel replacement. Plenty of other users though experiencing what you’re describing.

1 Like

Little information from my case.
I got newer firmware 5339, but it wont help with platter freeze.
We tested my platters and they have connection issues… the platter believes that you have finger on it, even when tou dont touch it, thats why music freezes.

With this knowledge, it doesnt have anything to do with software, and im happy to know it.
Trust fot Djay Pro is 100% but for m8 pro, its pretty low at the moment.

I have been told to get my mixon to service, its 3 months old now, so we will see if i can send it back and swap it to different device.
If im eligible to refund i try to get FLX10, and will be waiting upcoming support for it :fire:

I cant wait 2 months to get it back, theres tons of gigs to play!

1 Like

I feel your pain. Mines been at service centre 7 weeks. I returned through Bop Dj and have put a complaint in. Im waiting to see what integrations come down the line. Although I am tempted to get Rane one.

1 Like

Yeah, i will ask from my seller that is it possible to change to a different product with some cash in it… Tomorrow will be smarter :fire:

Best of luck with whatever you choose.

1 Like

Thanks for the information @Lex_Willer

Have you tried the controller with a different software? i.e. Virtual DJ?
In my case, I have the same problem as you, but strangely it only manifests in DJay Pro, not in Virtual DJ.

Moreover, there are also other users with the same problem with different controllers, i.e.:
https://community.algoriddim.com/t/play-pause-stops-working-and-sticky-scratch/26833?u=mrbig1964

I’m not here to defend or attack Algoriddim or Reloop.
I only want my problem solved.

But most of the evidences I collected until now points towards DJay having some kind of intermittent bug…

Just to describe what happen to me, today, when I was rehearsing for a set.
I was using channels 1, 2 (both on USB) and channel 1 (vinyl).
I’ve run into the same problem as described above in channel 2.
No matter what I do, the play button didn’t work.
I was cueing a new track in channel 2, the track was stopped and there was nothing that I could make that could restart that track.
Then I went to channel 4 (therefore using the same hardware jogwheel, play button and so on) loaded the track and start djaying without problem.
After this, I loaded a new track into channel 2 and, once again, everything was working normally.
If it was an hardware fault probably switching from channel 2 to channel 4 didn’t had been able to solve the problem….

Thanks for the additional info @MrBig1964. I’ve passed this onto the engineering team to see what they think.

Flipping to another deck could be a workaround, I will try, but after you experience the start is not working it basically is too late already.

Edit: Never mind the text below, that issue seems to be solved … \o/

But another thought I have is this. I have similar issues with a generic controller, that has no specific jog wheels, just endless rotary knobs of which I use one to scratch, just for getting a track in position, obviously not doing any real scratching with that. After Algoriddm structurally did not react, also because it was difficult for me to make a video to show it, I kind of concluded it was a controller issue indeed. I guess real jog wheels are handled differently by the controller and maybe the midi is mapped differently as compared to what a simple rotary encoder is capable of.

Can anyone show how their jogwheels are mapped in Djay? Maybe there is more going on than just assigning the rotary 3Fh/41h or 01h/7Fh to ‘scratch’ or ‘scratch without touch detection’?
Or maybe, like a problem with using 3Fh/41h for library scroll, it could be that a similar problem occurs when using 3Fh/41h for scratch?

At first I thought the new firmware fixed the issues with stuck play button. However, to update the firmware, I swiched from usb port B to A without switching back again. It came to my mind and the play button issue came back when connecting to usb port B.

Atleast there is a workaround using port A, but the root remains unresolved.