DDJ-400 no longer works - djay Pro AI Mac/iOS

I wanted to use a new DDJ-400 with Djay Pro AI again and had to find out that many things don’t work anymore - neither with the integrated nor with my own configuration. The jogwheels are no longer usable, but can be reassigned in the mapping. But the knob to select the titles can no longer be used, it is no longer recognized by Djay Pro. What happened there? Is this due to Djay Pro or maybe it is a problem with the hardware of the controller? With Rekordbox on the MacBook, the controller is perfectly usable, so I don’t think the device is broken.

Are you on the latest update?

Just today I installed the latest version from the store. I haven’t had a DDJ-400 in use for the last few weeks, but about four weeks ago everything was working fine. Since then, I think there have been two updates to Djay Pro AI.

Were you messing around with the XML file for it?

No. And I don’t have any access to the integrated configuration, at least not on the iPad.
What irritates me the most is that the rotation of the library button is not registered and displayed at all, the corresponding midi note is not displayed in any case. The pressure on the button, on the other hand, is implemented directly.

Hi @Chris_R,

We’re sorry to hear that you’ve been having issues between your DDJ-400 and djay.

Have you tried as of recent to use an app like MIDI Monitor for Mac to confirm whether or not the DDJ-400 is behaving as intended in order to conclude whether or not this may be a software issue or a hardware one?

Additionally, can you think of any possible changes in your setup which could’ve caused these issues such as Mac updates, changes in cables, etc?

Happily awaiting your reply!

I tried Midi Monitor today and it doesn’t recognize me when I use the knob to navigate through the music library. So it might actually be a problem with the controller itself. On the other hand, it works fine with Rekordbox on the Mac.
I haven’t made any changes to the configuration other than a firmware update from 1.02 to 1.03. But even that was a few weeks ago, so I can’t say for sure if the problems occurred at the same time.
I think I’ll contact the dealer about this and try to get a replacement unit.

1 Like

I am also having the same issue. Rotary works when shifting between folders and selecting. When I try to scroll up/down track list this doesn’t work. Please help

Hi @Francis_S,

Thanks for reaching out about this issue and for sharing all of the requested information about your device and the issue itself up front. I’ve moved your post over to this other already existing thread that is for monitoring this issue on djay Pro AI on Mac (the one you originally posted on is for djay Pro for Windows).

I’ve passed all of the information you’ve provided to our Dev Team for further testing, and we’ll keep you updated here on this thread. Thanks in advance for your patience!

DDJ-400 with Djay Pro AI and the jog wheels are not responsive. When I first used them together several months ago they were fine but now they’re wheels are completely unresponsive.

Many Thanks


1 Like

Is this the same DDJ 400 you were using a few months ago or is this a newer model? This sounds like the same problem I’ve described here before. There doesn’t seem to be a solution yet.

Hi Chris,
Thanks for responding It was an old model that worked with it before.

Then it seems to be the same as mine. I also replaced my DDJ 400 with a new one and it stopped working. Maybe Pioneer has changed something internally. With Rekordbox it’s no problem, everything runs as it should.
For me, it is no longer so relevant, I have the DDJ 400 then returned and now wait that the Flx4 is officially supported. I’ve also been using another controller as my main device for a while now, but it would be a pity if the DDJ 400 is no longer supported “out of the box” after all these years. This has always been the controller that first comes to mind when talking about DJay Pro, especially for beginners (but not only them).

Hi @jc_mighty,

Thanks for posting to the community for the first time! I’m sorry to hear that you’ve been experiencing this issue as of late.

Did you notice the DDJ-400 stopped working after a particular update to djay?

Additionally, @Chris_R, when you received your new DDJ-400 was it working for a brief period of time before it stopped working with djay once more?

Please note that the DDJ-FLX4 is now natively supported in djay for macOS and iOS. See our release notes post on this for more information linked below.

I’ve gone ahead and merged your original thread with @Chris_R’s previous thread on the matter as well for better tracking of this issue. Looking forward to your reply!

No, the new device did not work from the beginning.

The new update did not resolve the issue. Also telling me about another controller s not exceptable when your logo is on the box for the DDJ-400.

My controller doesn’t show up on Algoriddim. It works on rekordbox.
What can I do?

  • Device model: MAC
  • Version of operating system: latest
  • Version of djay: latest
  • Hardware/controllers used: DDJ 400
1 Like

How old is the DDJ-400? If it’s one of the more recent models, there’s nothing you can do, I’m afraid. I’ve described the problem here before, at some point they were no longer compatible with Djay Pro, or only to a limited extent.

1 Like

Hi @Baro, I’ve merged your post with this existing topic. Please use the search tool before creating new topics. Thanks!